Kategóriák
Hírek Tech

Megérkezett a PHP 8 a Webonic-ra

November 26-án megjelent a legfrissebb PHP 8 verzió. A korábbi PHP 7.4 verzióval ellentétben ez egy jelentős frissítés számos újdonsággal, így felmerülhetnek majd inkompatibilitási problémák is, amire a fejlesztőknek és weboldal tulajdonosoknak fel kell készülni.

PHP 8 és a Webonic

Jó hír, hogy a Webonic-nál már most elérhető az új verzió! Ha szeretnéd tesztelni, akkor nem kell mást tenned, mint belépni a WebAdmin felületre, és megváltoztatni a PHP verziót.

Mielőtt azonban élesíted, érdemes tesztet végezni az oldalak funkcióin és beállításain, hogy kiderüljön kompatibilisak-e az új PHP 8 verzióval. Javasoljuk, hogy emiatt vedd fel a kapcsolatot a weboldalad fejlesztőjével!

WordPress és egyéb CMS

A WordPress legújabb 5.6 verziója elméletileg támogatja a PHP 8 verzióját. Ugyanakkor a fejlesztők még “béta kompatibilitásról” beszélnek. Ennek oka, hogy a PHP 8 számos olyan változást hoz, ami nem kompatibilis a korábbi PHP 7.x verziókkal, szükséges lesz a bővítményeket és témákat/sablonokat a PHP 8 verziójára felkészíteni.

A közelgő Drupal 9.1 (RC1, RC3) támogatja a PHP 8 verzióját, de a készítők szerint (legalábbis az RC1 leírása alapján), teljeskörű támogatásról majd csak a Drupal 9.2. verziónál beszélhetünk.

Általánosságban elmondható, hogy a többi CMS is hasonló helyzetben van, érdemes átnézni a frissítésekre vonatkozó dokumentációt.

Az új PHP 8 funkciók nem kompatibilisek a PHP 7 és PHP 5 verziókkal. A PHP korábbi verzióit használó oldalakon pedig kritikus hibákat is okozhat.

Minden évben új fő verzió

A PHP fő verzióinak frissítése évente egyszer szokott megtörténni, általában novemberben, vagy decemberben. Az új fő verzió érkezésével a korábbi verzió hivatalos támogatása megszűnik. A PHP 8 verzió esetében:

  • A PHP 7.2 verzió támogatása megszűnik.
  • A PHP 7.3 verzió pedig csak biztonsági frissítéseket kap.

A Webonic-nál is tartjuk magunkat ezekhez a frissítésekhez. Emiatt mi is kivezetjük a korábbi verziók támogatását és arra biztatjuk a weboldalak tulajdonosait, hogy frissítsék oldalukat ennek megfelelően. 2019 óta például már nem lehet PHP 5 verziót futtatni, és a teljes kivezetését tervezzük. A webtárhelyen támogatott verziókról ezen a linken találsz bővebb információt.

Javasolt verzió

A weboldalad megfelelő védelmének és teljesítményének érdekében a PHP 7.4 verziójának használatát javasoljuk. Az új hosting csomagok esetén ez már alapbeállítás a Webonic-nál.

Hivatalos PHP 8 dokumentáció (angolul):
PHP 8 újdonságok, leírás
PHP 7.4 -> PHP 8 frissítés, migrálás

Vélemény, hozzászólás?

Az email címet nem tesszük közzé. A kötelező mezőket * karakterrel jelöltük